summaryrefslogtreecommitdiff
path: root/libotr-3.2.0/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libotr-3.2.0/src/Makefile.am')
-rw-r--r--libotr-3.2.0/src/Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/libotr-3.2.0/src/Makefile.am b/libotr-3.2.0/src/Makefile.am
new file mode 100644
index 0000000..c75fcbe
--- /dev/null
+++ b/libotr-3.2.0/src/Makefile.am
@@ -0,0 +1,13 @@
+INCLUDES = @LIBGCRYPT_CFLAGS@
+
+lib_LTLIBRARIES = libotr.la
+
+libotr_la_SOURCES = privkey.c context.c proto.c b64.c dh.c mem.c message.c \
+ userstate.c tlv.c auth.c sm.c
+
+libotr_la_LDFLAGS = -version-info @LIBOTR_LIBTOOL_VERSION@ @LIBS@ @LIBGCRYPT_LIBS@
+
+otrincdir = $(includedir)/libotr
+
+otrinc_HEADERS = b64.h context.h dh.h mem.h message.h privkey.h proto.h \
+ version.h userstate.h tlv.h serial.h auth.h sm.h privkey-t.h