summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMataes <mataes2007@gmail.com>2017-11-30 08:38:37 +0300
committerGitHub <noreply@github.com>2017-11-30 08:38:37 +0300
commitc3e40028c06d76a4fd20255c6dd39bcce3f7b229 (patch)
treeb28e593dfbe75d625761636c39e0ec0b1dd44d8e /CMakeLists.txt
parent0a95d1c9e2791898c03eab04a06932ec65f3a934 (diff)
parentb1103b6eb24f654e2e2666b0c86a6206920fd23a (diff)
Merge pull request #1046 from protomors/cmake-update
Cmake updates
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5328c8ddf4..e76b31a297 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,6 +2,8 @@ cmake_minimum_required (VERSION 2.8)
project (Miranda)
+find_package(OpenSSL)
+
set_directory_properties(PROPERTIES COMPILE_DEFINITIONS "_UNICODE;UNICODE;_CRT_SECURE_NO_WARNINGS;_CRT_NONSTDC_NO_WARNINGS")
if(CMAKE_CL_64)
link_directories(${CMAKE_SOURCE_DIR}/libs/win64)
@@ -9,7 +11,6 @@ else()
link_directories(${CMAKE_SOURCE_DIR}/libs/win32)
endif()
include_directories(${CMAKE_SOURCE_DIR}/include ${CMAKE_SOURCE_DIR}/include/msapi ${CMAKE_SOURCE_DIR}/plugins/ExternalAPI)
-set(COMMON_LIBS winmm.lib Wtsapi32.lib netapi32.lib pdh.lib shlwapi.lib Strmiids.lib gdiplus.lib dbghelp.lib Setupapi.lib msimg32.lib comctl32.lib ws2_32.lib UxTheme.lib)
add_subdirectory(libs)
add_subdirectory(src)