summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorprotomors <protomors@gmail.com>2017-11-08 02:31:53 +0600
committerprotomors <protomors@gmail.com>2017-11-29 16:48:26 +0300
commite62e68d8dad3e554fdd9a41cea6ecdf35cde3102 (patch)
tree4a8b01b171c2a4e279c3162b5f3797c1af619aa2 /CMakeLists.txt
parent6421856622260f6b92637b57f04306c8ae94208a (diff)
CMake: clean up library dependencies.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 5328c8ddf4..e76b31a297 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,6 +2,8 @@ cmake_minimum_required (VERSION 2.8)
project (Miranda)
+find_package(OpenSSL)
+
set_directory_properties(PROPERTIES COMPILE_DEFINITIONS "_UNICODE;UNICODE;_CRT_SECURE_NO_WARNINGS;_CRT_NONSTDC_NO_WARNINGS")
if(CMAKE_CL_64)
link_directories(${CMAKE_SOURCE_DIR}/libs/win64)
@@ -9,7 +11,6 @@ else()
link_directories(${CMAKE_SOURCE_DIR}/libs/win32)
endif()
include_directories(${CMAKE_SOURCE_DIR}/include ${CMAKE_SOURCE_DIR}/include/msapi ${CMAKE_SOURCE_DIR}/plugins/ExternalAPI)
-set(COMMON_LIBS winmm.lib Wtsapi32.lib netapi32.lib pdh.lib shlwapi.lib Strmiids.lib gdiplus.lib dbghelp.lib Setupapi.lib msimg32.lib comctl32.lib ws2_32.lib UxTheme.lib)
add_subdirectory(libs)
add_subdirectory(src)