summaryrefslogtreecommitdiff
path: root/libs/libaxolotl/src/protobuf-c/CMakeLists.txt
diff options
context:
space:
mode:
authorGeorge Hazan <george.hazan@gmail.com>2016-01-26 08:28:32 +0000
committerGeorge Hazan <george.hazan@gmail.com>2016-01-26 08:28:32 +0000
commit2a82a9154f9d6e0b5658c82cd346051017339a1e (patch)
tree8321c2d1897d4026e68064241014eef4a57ddc9d /libs/libaxolotl/src/protobuf-c/CMakeLists.txt
parent80148955f82c205cc94f0112e0fbfe8f91bc4330 (diff)
libaxolotl - initial commit
git-svn-id: http://svn.miranda-ng.org/main/trunk@16169 1316c22d-e87f-b044-9b9b-93d7a3e3ba9c
Diffstat (limited to 'libs/libaxolotl/src/protobuf-c/CMakeLists.txt')
-rw-r--r--libs/libaxolotl/src/protobuf-c/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/libs/libaxolotl/src/protobuf-c/CMakeLists.txt b/libs/libaxolotl/src/protobuf-c/CMakeLists.txt
new file mode 100644
index 0000000000..63f18db8ae
--- /dev/null
+++ b/libs/libaxolotl/src/protobuf-c/CMakeLists.txt
@@ -0,0 +1,17 @@
+IF(CMAKE_COMPILER_IS_GNUCC OR CMAKE_C_COMPILER_ID MATCHES "Clang")
+ SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-shadow")
+ENDIF(CMAKE_COMPILER_IS_GNUCC OR CMAKE_C_COMPILER_ID MATCHES "Clang")
+
+IF(CMAKE_COMPILER_IS_GNUCC)
+ SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-sign-compare -Wno-sign-conversion")
+ENDIF(CMAKE_COMPILER_IS_GNUCC)
+
+IF(CMAKE_C_COMPILER_ID MATCHES "Clang")
+ SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-shorten-64-to-32")
+ENDIF(CMAKE_C_COMPILER_ID MATCHES "Clang")
+
+set(protobuf_SRCS
+ protobuf-c.c
+)
+
+add_library(protobuf-c OBJECT ${protobuf_SRCS})