summaryrefslogtreecommitdiff
path: root/plugins/Clist_ng/AGG/src/Makefile.am
diff options
context:
space:
mode:
authorTobias Weimer <wishmaster51@googlemail.com>2015-07-12 14:10:16 +0000
committerTobias Weimer <wishmaster51@googlemail.com>2015-07-12 14:10:16 +0000
commitf4ce2b5c214cce406dbd7a73dc7f35ae409546ad (patch)
tree533cc821ffc9c5664c075930be6a40fde9593aba /plugins/Clist_ng/AGG/src/Makefile.am
parent71a88c6d8c4578ca24e02a5c6f4860c206e7c6da (diff)
Clist NG:
Commit of CList NG by silvercircle from https://github.com/silvercircle/miranda-ng This is based on clist_nicer and Anti-Grain Geometry: http://www.antigrain.com/ This is the first version that actually compiles. Do NOT use it in production environment! git-svn-id: http://svn.miranda-ng.org/main/trunk@14543 1316c22d-e87f-b044-9b9b-93d7a3e3ba9c
Diffstat (limited to 'plugins/Clist_ng/AGG/src/Makefile.am')
-rw-r--r--plugins/Clist_ng/AGG/src/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/plugins/Clist_ng/AGG/src/Makefile.am b/plugins/Clist_ng/AGG/src/Makefile.am
new file mode 100644
index 0000000000..f9a35fb27b
--- /dev/null
+++ b/plugins/Clist_ng/AGG/src/Makefile.am
@@ -0,0 +1,47 @@
+SUBDIRS = ctrl . platform
+
+INCLUDES = -I$(top_srcdir)/include
+
+lib_LTLIBRARIES = libagg.la
+
+libagg_la_LDFLAGS = -no-undefined -version-info @AGG_LIB_VERSION@
+libagg_la_SOURCES = agg_arc.cpp \
+ agg_arrowhead.cpp \
+ agg_bezier_arc.cpp \
+ agg_bspline.cpp \
+ agg_curves.cpp \
+ agg_embedded_raster_fonts.cpp \
+ agg_gsv_text.cpp \
+ agg_image_filters.cpp \
+ agg_line_aa_basics.cpp \
+ agg_line_profile_aa.cpp \
+ agg_rounded_rect.cpp \
+ agg_sqrt_tables.cpp \
+ agg_trans_affine.cpp \
+ agg_trans_double_path.cpp \
+ agg_trans_single_path.cpp \
+ agg_trans_warp_magnifier.cpp \
+ agg_vcgen_bspline.cpp \
+ agg_vcgen_contour.cpp \
+ agg_vcgen_dash.cpp \
+ agg_vcgen_markers_term.cpp \
+ agg_vcgen_smooth_poly1.cpp \
+ agg_vcgen_stroke.cpp \
+ agg_vpgen_clip_polygon.cpp \
+ agg_vpgen_clip_polyline.cpp \
+ agg_vpgen_segmentator.cpp
+
+if ENABLE_GPC
+GPCLD=$(top_builddir)/gpc/libagggpc.la
+else
+GPCLD=
+endif
+
+if ENABLE_CTRL
+CTRLLD=$(top_builddir)/src/ctrl/libaggctrl.la
+else
+CTRLLD=
+endif
+
+libagg_la_LIBADD = $(GPCLD) $(CTRLLD)
+