summaryrefslogtreecommitdiff
path: root/plugins/MirOTR/ekhtml/testsuite/Makefile.am
diff options
context:
space:
mode:
authorKirill Volinsky <mataes2007@gmail.com>2012-05-19 18:01:32 +0000
committerKirill Volinsky <mataes2007@gmail.com>2012-05-19 18:01:32 +0000
commitb1509f22892dc98057c750e7fae39ded5cea3b09 (patch)
tree6bdcc9379ae86339a67022b758575729d1304074 /plugins/MirOTR/ekhtml/testsuite/Makefile.am
parente7a776a6f5ab323cd9dd824e815846ef268fa7f1 (diff)
added MirOTR
git-svn-id: http://svn.miranda-ng.org/main/trunk@83 1316c22d-e87f-b044-9b9b-93d7a3e3ba9c
Diffstat (limited to 'plugins/MirOTR/ekhtml/testsuite/Makefile.am')
-rw-r--r--plugins/MirOTR/ekhtml/testsuite/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/plugins/MirOTR/ekhtml/testsuite/Makefile.am b/plugins/MirOTR/ekhtml/testsuite/Makefile.am
new file mode 100644
index 0000000000..adbda98f46
--- /dev/null
+++ b/plugins/MirOTR/ekhtml/testsuite/Makefile.am
@@ -0,0 +1,26 @@
+EKHTML_LIB = $(top_srcdir)/src/libekhtml.la
+
+EXTRA_DIST = \
+ ek_sgmllib.py \
+ gen_html.py \
+ plparser.pl \
+ pyparser.py \
+ test_basic.sh \
+ test_bogus_feedsize.sh \
+ test_crazypage.sh \
+ tstpages
+
+noinst_PROGRAMS = tester
+
+tester_SOURCES = tester.c
+tester_LDADD = $(EKHTML_LIB)
+tester_LDFLAGS = -static
+tester_DEPENDENCIES = $(EKHTML_LIB)
+
+$(EKHTML_LIB):
+ cd $(top_srcdir)/src && $(MAKE)
+
+TESTS = test_basic.sh test_crazypage.sh test_bogus_feedsize.sh
+
+dist-hook:
+ rm -rf `find $(distdir)/tstpages -name CVS`