summaryrefslogtreecommitdiff
path: root/protocols/Sametime/src/glib/pcre/Makefile.am
diff options
context:
space:
mode:
authorGeorge Hazan <george.hazan@gmail.com>2014-03-22 13:34:19 +0000
committerGeorge Hazan <george.hazan@gmail.com>2014-03-22 13:34:19 +0000
commit79b554fe05162550656da3c4e459fb717dc4dadf (patch)
tree34b5856bb397b145e2a6e6b317742b73ff53ec9f /protocols/Sametime/src/glib/pcre/Makefile.am
parent739fd4137010dc56881cf8328770b3175a2f2696 (diff)
glib inlined into SameTime
git-svn-id: http://svn.miranda-ng.org/main/trunk@8685 1316c22d-e87f-b044-9b9b-93d7a3e3ba9c
Diffstat (limited to 'protocols/Sametime/src/glib/pcre/Makefile.am')
-rw-r--r--protocols/Sametime/src/glib/pcre/Makefile.am57
1 files changed, 57 insertions, 0 deletions
diff --git a/protocols/Sametime/src/glib/pcre/Makefile.am b/protocols/Sametime/src/glib/pcre/Makefile.am
new file mode 100644
index 0000000000..07e8526ed7
--- /dev/null
+++ b/protocols/Sametime/src/glib/pcre/Makefile.am
@@ -0,0 +1,57 @@
+include $(top_srcdir)/Makefile.decl
+
+INCLUDES = \
+ -DG_LOG_DOMAIN=\"GLib-GRegex\" \
+ -DSUPPORT_UCP \
+ -DSUPPORT_UTF8 \
+ -DNEWLINE=-1 \
+ -DMATCH_LIMIT=10000000 \
+ -DMATCH_LIMIT_RECURSION=8192 \
+ -DMAX_NAME_SIZE=32 \
+ -DMAX_NAME_COUNT=10000 \
+ -DMAX_DUPLENGTH=30000 \
+ -DLINK_SIZE=2 \
+ -DPOSIX_MALLOC_THRESHOLD=10 \
+ -DPCRE_STATIC \
+ $(glib_INCLUDES) \
+ @GLIB_DEBUG_FLAGS@ \
+ -DG_DISABLE_DEPRECATED \
+ -DGLIB_COMPILATION \
+ $(DEPRECATED_FLAGS)\
+ $(WARN_CFLAGS) \
+ $(PCRE_WARN_CFLAGS) \
+ $(DEP_CFLAGS)
+
+noinst_LTLIBRARIES = libpcre.la
+
+libpcre_headers =
+
+libpcre_la_SOURCES = \
+ pcre_compile.c \
+ pcre_chartables.c \
+ pcre_config.c \
+ pcre_dfa_exec.c \
+ pcre_exec.c \
+ pcre_fullinfo.c \
+ pcre_get.c \
+ pcre_globals.c \
+ pcre_newline.c \
+ pcre_ord2utf8.c \
+ pcre_study.c \
+ pcre_tables.c \
+ pcre_try_flipped.c \
+ pcre_ucp_searchfuncs.c \
+ pcre_xclass.c \
+ pcre.h \
+ pcre_internal.h \
+ ucp.h \
+ $(libpcre_headers)
+
+libpcre_la_LIBADD = $(DEP_LIBS)
+
+libpcre_la_LDFLAGS = -no-undefined
+
+EXTRA_DIST += \
+ COPYING \
+ makefile.msc
+