summaryrefslogtreecommitdiff
path: root/protocols/SkypeWeb/CMakeLists.txt
diff options
context:
space:
mode:
authorVitaly Svyastyn <protomors@gmail.com>2017-10-31 13:32:16 +0200
committerGeorge Hazan <ghazan@miranda.im>2017-10-31 14:32:16 +0300
commit4d9bf8032dd659e091394d688b6a2c59bf222240 (patch)
tree517f405276c562044b8f7f32a9475e4bac7cf94e /protocols/SkypeWeb/CMakeLists.txt
parent9437834f8f4d3abf32a8629747385d666c652084 (diff)
Initial CMake support. (#1013)
* CMake files for building application and core library. * CMake files for core plugins. Now it runs! * CMake files for some plugins.
Diffstat (limited to 'protocols/SkypeWeb/CMakeLists.txt')
-rw-r--r--protocols/SkypeWeb/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/protocols/SkypeWeb/CMakeLists.txt b/protocols/SkypeWeb/CMakeLists.txt
new file mode 100644
index 0000000000..739bbe8aec
--- /dev/null
+++ b/protocols/SkypeWeb/CMakeLists.txt
@@ -0,0 +1,6 @@
+file(GLOB SOURCES "src/*.h" "src/requests/*.h" "src/requests/asm/*.h" "src/*.cpp" "res/*.rc")
+set(TARGET SkypeWeb)
+include(${CMAKE_SOURCE_DIR}/cmake/plugin.cmake)
+target_link_libraries(${TARGET} libjson)
+add_subdirectory(proto_conn_skype)
+add_subdirectory(proto_skype) \ No newline at end of file