summaryrefslogtreecommitdiff
path: root/protocols/Telegram/CMakeLists.txt
diff options
context:
space:
mode:
authorVitaly Svyastyn <protomors@gmail.com>2017-11-05 19:33:01 +0600
committerGeorge Hazan <ghazan@miranda.im>2017-11-05 16:33:01 +0300
commit52921a9e13484319df2d4f1153521f3f5e12b932 (patch)
tree5c6b99a6e59958778ab1cdfa61a0848d3211eb0a /protocols/Telegram/CMakeLists.txt
parentdb6f3932affcc9397c9fbed99d344388a585add5 (diff)
More CMake (#1016)
* Generate version information before build. * Removed /EHsc from compile options. * CMake files for the rest of protocols. * CMake 64 bit build. * CMake: precompiled headers.
Diffstat (limited to 'protocols/Telegram/CMakeLists.txt')
-rw-r--r--protocols/Telegram/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/protocols/Telegram/CMakeLists.txt b/protocols/Telegram/CMakeLists.txt
new file mode 100644
index 0000000000..6fd3fc555a
--- /dev/null
+++ b/protocols/Telegram/CMakeLists.txt
@@ -0,0 +1,29 @@
+file(GLOB SOURCES "src/*.h" "res/*.rc"
+"src/tgl/auto/auto-autocomplete.c"
+"src/tgl/auto/auto-fetch-ds.c"
+"src/tgl/auto/auto-fetch.c"
+"src/tgl/auto/auto-free-ds.c"
+"src/tgl/auto/auto-print-ds.c"
+"src/tgl/auto/auto-skip.c"
+"src/tgl/auto/auto-store-ds.c"
+"src/tgl/auto/auto-store.c"
+"src/tgl/auto/auto-types.c"
+"src/tgl/binlog.c"
+"src/tgl/mime-types.c"
+"src/tgl/mtproto-client.c"
+"src/tgl/mtproto-common.c"
+"src/tgl/mtproto-utils.c"
+"src/tgl/queries.c"
+"src/tgl/structures.c"
+"src/tgl/tg-mime-types.c"
+"src/tgl/tgl-net.c"
+"src/tgl/tgl-timers.c"
+"src/tgl/tgl.c"
+"src/tgl/tools.c"
+"src/tgl/updates.c"
+)
+include_directories(${CMAKE_SOURCE_DIR}/libs/libevent/include)
+set(TARGET Telegram)
+include(${CMAKE_SOURCE_DIR}/cmake/plugin.cmake)
+set_target_properties(${TARGET} PROPERTIES COMPILE_DEFINITIONS "HAVE_CONFIG_H")
+target_link_libraries(${TARGET} Zlib libevent libeay32.lib ssleay32.lib) \ No newline at end of file