summaryrefslogtreecommitdiff
path: root/protocols/Twitter/oauth/tests/Makefile.am
diff options
context:
space:
mode:
authorVadim Dashevskiy <watcherhd@gmail.com>2012-06-06 20:17:58 +0000
committerVadim Dashevskiy <watcherhd@gmail.com>2012-06-06 20:17:58 +0000
commitab92c2a5cd5427bf8a33d06afdb64b88d2d640ed (patch)
treefc82f068ad7bf8e141b6148f2ff191eab56e1f5a /protocols/Twitter/oauth/tests/Makefile.am
parent441daff7dfc4cd80075cfbec3345192aab4353b5 (diff)
Twitter updated
git-svn-id: http://svn.miranda-ng.org/main/trunk@337 1316c22d-e87f-b044-9b9b-93d7a3e3ba9c
Diffstat (limited to 'protocols/Twitter/oauth/tests/Makefile.am')
-rw-r--r--protocols/Twitter/oauth/tests/Makefile.am44
1 files changed, 44 insertions, 0 deletions
diff --git a/protocols/Twitter/oauth/tests/Makefile.am b/protocols/Twitter/oauth/tests/Makefile.am
new file mode 100644
index 0000000000..55330a19ac
--- /dev/null
+++ b/protocols/Twitter/oauth/tests/Makefile.am
@@ -0,0 +1,44 @@
+check_PROGRAMS = oauthexample oauthdatapost tcwiki tceran tcother oauthtest oauthtest2 oauthsign oauthbodyhash
+ACLOCAL_AMFLAGS= -I m4
+
+OAUTHDIR =../src
+INCLUDES = -I$(srcdir)/$(OAUTHDIR)
+MYCFLAGS = @LIBOAUTH_CFLAGS@ @HASH_CFLAGS@ @CURL_CFLAGS@
+MYLDADD = $(OAUTHDIR)/liboauth.la
+LIBS = -lm @HASH_LIBS@ @CURL_LIBS@ @LIBS@
+
+tcwiki_SOURCES = selftest_wiki.c commontest.c commontest.h
+tcwiki_LDADD = $(MYLDADD)
+tcwiki_CFLAGS = $(MYCFLAGS) @TEST_UNICODE@
+
+tceran_SOURCES = selftest_eran.c commontest.c commontest.h
+tceran_LDADD = $(MYLDADD)
+tceran_CFLAGS = $(MYCFLAGS) @TEST_UNICODE@
+
+tcother_SOURCES = selftest_other.c commontest.c commontest.h
+tcother_LDADD = $(MYLDADD)
+tcother_CFLAGS = $(MYCFLAGS)
+
+oauthtest_SOURCES = oauthtest.c
+oauthtest_LDADD = $(MYLDADD)
+oauthtest_CFLAGS = $(MYCFLAGS)
+
+oauthtest2_SOURCES = oauthtest2.c
+oauthtest2_LDADD = $(MYLDADD)
+oauthtest2_CFLAGS = $(MYCFLAGS)
+
+oauthexample_SOURCES = oauthexample.c
+oauthexample_LDADD = $(MYLDADD)
+oauthexample_CFLAGS = $(MYCFLAGS)
+
+oauthsign_SOURCES = oauthsign.c
+oauthsign_LDADD = $(MYLDADD)
+oauthsign_CFLAGS = $(MYCFLAGS)
+
+oauthdatapost_SOURCES = oauthdatapost.c
+oauthdatapost_LDADD = $(MYLDADD)
+oauthdatapost_CFLAGS = $(MYCFLAGS)
+
+oauthbodyhash_SOURCES = oauthbodyhash.c
+oauthbodyhash_LDADD = $(MYLDADD)
+oauthbodyhash_CFLAGS = $(MYCFLAGS)