summaryrefslogtreecommitdiff
path: root/src/mir_app/CMakeLists.txt
diff options
context:
space:
mode:
authorVitaly Svyastyn <protomors@gmail.com>2017-11-05 19:33:01 +0600
committerGeorge Hazan <ghazan@miranda.im>2017-11-05 16:33:01 +0300
commit52921a9e13484319df2d4f1153521f3f5e12b932 (patch)
tree5c6b99a6e59958778ab1cdfa61a0848d3211eb0a /src/mir_app/CMakeLists.txt
parentdb6f3932affcc9397c9fbed99d344388a585add5 (diff)
More CMake (#1016)
* Generate version information before build. * Removed /EHsc from compile options. * CMake files for the rest of protocols. * CMake 64 bit build. * CMake: precompiled headers.
Diffstat (limited to 'src/mir_app/CMakeLists.txt')
-rw-r--r--src/mir_app/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/mir_app/CMakeLists.txt b/src/mir_app/CMakeLists.txt
index 8e72c06f59..fa73635191 100644
--- a/src/mir_app/CMakeLists.txt
+++ b/src/mir_app/CMakeLists.txt
@@ -1,4 +1,9 @@
-file(GLOB SOURCES "src/*.h" "src/*.cpp" "src/mir_app.def" "res/*.rc")
+file(GLOB SOURCES "src/*.h" "src/*.cpp" "res/*.rc")
+if(CMAKE_CL_64)
+ list(APPEND SOURCES "src/mir_app64.def")
+else()
+ list(APPEND SOURCES "src/mir_app.def")
+endif()
set(TARGET mir_app)
include(${CMAKE_SOURCE_DIR}/cmake/lib.cmake)