summaryrefslogtreecommitdiff
path: root/libs/libaxolotl/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libs/libaxolotl/src/CMakeLists.txt')
-rw-r--r--libs/libaxolotl/src/CMakeLists.txt90
1 files changed, 90 insertions, 0 deletions
diff --git a/libs/libaxolotl/src/CMakeLists.txt b/libs/libaxolotl/src/CMakeLists.txt
new file mode 100644
index 0000000000..3900713add
--- /dev/null
+++ b/libs/libaxolotl/src/CMakeLists.txt
@@ -0,0 +1,90 @@
+include_directories(
+ .
+ curve25519/ed25519/nacl_includes
+ curve25519/ed25519/additions
+ curve25519/ed25519/sha512
+ curve25519/ed25519
+ curve25519
+)
+
+set(protobuf_SRCS
+ LocalStorageProtocol.pb-c.c
+ WhisperTextProtocol.pb-c.c
+ FingerprintProtocol.pb-c.c
+)
+
+set(axolotl_SRCS
+ vpool.c
+ vpool.h
+ axolotl.c
+ axolotl.h
+ axolotl_types.h
+ axolotl_internal.h
+ curve.c
+ curve.h
+ hkdf.c
+ hkdf.h
+ ratchet.c
+ ratchet.h
+ protocol.c
+ protocol.h
+ session_state.c
+ session_state.h
+ session_record.c
+ session_record.h
+ session_pre_key.c
+ session_pre_key.h
+ session_builder.c
+ session_builder.h
+ session_cipher.c
+ session_cipher.h
+ key_helper.c
+ key_helper.h
+ sender_key.c
+ sender_key.h
+ sender_key_state.c
+ sender_key_state.h
+ sender_key_record.c
+ sender_key_record.h
+ group_session_builder.c
+ group_session_builder.h
+ group_cipher.c
+ group_cipher.h
+ fingerprint.c
+ fingerprint.h
+)
+
+add_subdirectory(curve25519)
+add_subdirectory(protobuf-c)
+
+add_library(axolotl-c
+ ${protobuf_SRCS}
+ ${axolotl_SRCS}
+ $<TARGET_OBJECTS:curve25519>
+ $<TARGET_OBJECTS:protobuf-c>
+)
+
+INSTALL(
+ FILES
+ axolotl.h
+ axolotl_types.h
+ curve.h
+ hkdf.h
+ ratchet.h
+ protocol.h
+ session_state.h
+ session_record.h
+ session_pre_key.h
+ session_builder.h
+ session_cipher.h
+ key_helper.h
+ sender_key.h
+ sender_key_state.h
+ sender_key_record.h
+ group_session_builder.h
+ group_cipher.h
+ fingerprint.h
+ DESTINATION include/axolotl
+)
+
+INSTALL(TARGETS axolotl-c DESTINATION lib)