summaryrefslogtreecommitdiff
path: root/libs/libaxolotl/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libs/libaxolotl/src/CMakeLists.txt')
-rw-r--r--libs/libaxolotl/src/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/libs/libaxolotl/src/CMakeLists.txt b/libs/libaxolotl/src/CMakeLists.txt
index 54a24d0a6c..f92978850d 100644
--- a/libs/libaxolotl/src/CMakeLists.txt
+++ b/libs/libaxolotl/src/CMakeLists.txt
@@ -1,3 +1,7 @@
+if(BUILD_SHARED_LIBS)
+ find_library(M_LIB m)
+endif()
+
include_directories(
.
curve25519/ed25519/nacl_includes
@@ -67,6 +71,14 @@ add_library(signal-protocol-c
$<TARGET_OBJECTS:protobuf-c>
)
+if(BUILD_SHARED_LIBS)
+ target_link_libraries(signal-protocol-c ${M_LIB})
+ set_target_properties(signal-protocol-c PROPERTIES
+ VERSION ${SIGNAL_PROTOCOL_C_VERSION}
+ SOVERSION ${SIGNAL_PROTOCOL_C_VERSION_MAJOR}
+ )
+endif()
+
INSTALL(
FILES
signal_protocol.h