summaryrefslogtreecommitdiff
path: root/libs/libaxolotl/src/protobuf-c/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libs/libaxolotl/src/protobuf-c/CMakeLists.txt')
-rw-r--r--libs/libaxolotl/src/protobuf-c/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/libs/libaxolotl/src/protobuf-c/CMakeLists.txt b/libs/libaxolotl/src/protobuf-c/CMakeLists.txt
new file mode 100644
index 0000000000..63f18db8ae
--- /dev/null
+++ b/libs/libaxolotl/src/protobuf-c/CMakeLists.txt
@@ -0,0 +1,17 @@
+IF(CMAKE_COMPILER_IS_GNUCC OR CMAKE_C_COMPILER_ID MATCHES "Clang")
+ SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-shadow")
+ENDIF(CMAKE_COMPILER_IS_GNUCC OR CMAKE_C_COMPILER_ID MATCHES "Clang")
+
+IF(CMAKE_COMPILER_IS_GNUCC)
+ SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-sign-compare -Wno-sign-conversion")
+ENDIF(CMAKE_COMPILER_IS_GNUCC)
+
+IF(CMAKE_C_COMPILER_ID MATCHES "Clang")
+ SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-shorten-64-to-32")
+ENDIF(CMAKE_C_COMPILER_ID MATCHES "Clang")
+
+set(protobuf_SRCS
+ protobuf-c.c
+)
+
+add_library(protobuf-c OBJECT ${protobuf_SRCS})