summaryrefslogtreecommitdiff
path: root/protocols/ICQCorp/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'protocols/ICQCorp/CMakeLists.txt')
-rw-r--r--protocols/ICQCorp/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/protocols/ICQCorp/CMakeLists.txt b/protocols/ICQCorp/CMakeLists.txt
new file mode 100644
index 0000000000..9e3d58ba26
--- /dev/null
+++ b/protocols/ICQCorp/CMakeLists.txt
@@ -0,0 +1,15 @@
+set_directory_properties(PROPERTIES COMPILE_DEFINITIONS "")
+
+file(GLOB SOURCES "src/*.h" "res/*.rc"
+"src/corp.cpp"
+"src/event.cpp"
+"src/options.cpp"
+"src/packet.cpp"
+"src/protocol.cpp"
+"src/services.cpp"
+"src/socket.cpp"
+"src/transfer.cpp"
+"src/user.cpp"
+)
+set(TARGET ICQCorp)
+include(${CMAKE_SOURCE_DIR}/cmake/plugin.cmake) \ No newline at end of file