summaryrefslogtreecommitdiff
path: root/protocols/JabberG/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'protocols/JabberG/CMakeLists.txt')
-rw-r--r--protocols/JabberG/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/protocols/JabberG/CMakeLists.txt b/protocols/JabberG/CMakeLists.txt
new file mode 100644
index 0000000000..257a4cd8ae
--- /dev/null
+++ b/protocols/JabberG/CMakeLists.txt
@@ -0,0 +1,7 @@
+file(GLOB SOURCES "src/*.h" "src/*.cpp" "res/*.rc")
+set(TARGET Jabber)
+include_directories(${CMAKE_SOURCE_DIR}/libs/libaxolotl/src)
+include(${CMAKE_SOURCE_DIR}/cmake/plugin.cmake)
+target_link_libraries(${TARGET} Zlib libaxolotl libeay32.lib ssleay32.lib)
+add_subdirectory(jabber_xstatus)
+add_subdirectory(proto_jabber) \ No newline at end of file