summaryrefslogtreecommitdiff
path: root/protocols/Twitter/oauth/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'protocols/Twitter/oauth/Makefile.am')
-rw-r--r--protocols/Twitter/oauth/Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/protocols/Twitter/oauth/Makefile.am b/protocols/Twitter/oauth/Makefile.am
new file mode 100644
index 0000000000..bacc32a25f
--- /dev/null
+++ b/protocols/Twitter/oauth/Makefile.am
@@ -0,0 +1,39 @@
+ACLOCAL_AMFLAGS= -I m4
+SUBDIRS = @subdirs@
+
+EXTRA_DIST=liboauth.lsm.in oauth.pc.in Doxyfile.in \
+ COPYING.GPL COPYING.MIT LICENSE.OpenSSL \
+ m4
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = oauth.pc
+
+TESTS=tests/tcwiki@EXESUF@ tests/tceran@EXESUF@ tests/tcother@EXESUF@
+
+CLEANFILES = stamp-doxygen stamp-doc
+
+MAINTAINERCLEANFILES = \
+ src/Makefile.in \
+ tests/Makefile.in \
+ tests/atconfig \
+ doc/Makefile.in \
+ Makefile.in \
+ aclocal.m4 \
+ compile \
+ config.guess \
+ config.h.in \
+ config.sub \
+ configure \
+ depcomp \
+ install-sh \
+ missing
+
+dox: stamp-doxygen
+
+stamp-doxygen: src/oauth.h doc/mainpage.dox
+ $(DOXYGEN) Doxyfile && touch stamp-doxygen
+ cp doc/man/man3/oauth.h.3 doc/oauth.3
+ sed 's/ -\([qsdU]\)/ \\-\1/g' doc/man/man3/oauth.h.3 \
+ | sed 's/ -1 / \\-1 /' \
+ | sed 's/--/\\-\\-/' \
+ > doc/oauth.3