summaryrefslogtreecommitdiff
path: root/src/mir_app/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/mir_app/CMakeLists.txt')
-rw-r--r--src/mir_app/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/mir_app/CMakeLists.txt b/src/mir_app/CMakeLists.txt
index 8e72c06f59..fa73635191 100644
--- a/src/mir_app/CMakeLists.txt
+++ b/src/mir_app/CMakeLists.txt
@@ -1,4 +1,9 @@
-file(GLOB SOURCES "src/*.h" "src/*.cpp" "src/mir_app.def" "res/*.rc")
+file(GLOB SOURCES "src/*.h" "src/*.cpp" "res/*.rc")
+if(CMAKE_CL_64)
+ list(APPEND SOURCES "src/mir_app64.def")
+else()
+ list(APPEND SOURCES "src/mir_app.def")
+endif()
set(TARGET mir_app)
include(${CMAKE_SOURCE_DIR}/cmake/lib.cmake)