summaryrefslogtreecommitdiff
path: root/www-apps/trac/trac-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/trac/trac-9999.ebuild')
-rw-r--r--www-apps/trac/trac-9999.ebuild30
1 files changed, 3 insertions, 27 deletions
diff --git a/www-apps/trac/trac-9999.ebuild b/www-apps/trac/trac-9999.ebuild
index 2d5cb28..991c745 100644
--- a/www-apps/trac/trac-9999.ebuild
+++ b/www-apps/trac/trac-9999.ebuild
@@ -5,9 +5,6 @@
EAPI=3
inherit webapp subversion distutils
-#MY_PV=${PV/_beta/b}
-#MY_P=Trac-${MY_PV}
-#S=${WORKDIR}/${MY_P}
DESCRIPTION="Trac is a minimalistic web-based project management, wiki and bug/issue tracking system."
HOMEPAGE="http://trac.edgewall.com/"
@@ -16,12 +13,9 @@ SRC_URI=""
IUSE="cgi fastcgi mysql multirepos postgres sqlite subversion"
-ESVN_REPO_URI="http://svn.edgewall.org/repos/trac/trunk"
+ESVN_REPO_URI="https://svn.edgewall.org/repos/trac/trunk"
ESVN_PROJECT="${PN/-svn}"
ESVN_STORE_DIR="${DISTDIR}/svn-src"
-#ESVN_BOOTSTRAP="./reconf"
-
-#S="${WORKDIR}/${P/_/}"
@@ -69,21 +63,6 @@ RDEPEND="
!www-apps/trac-webadmin
"
-# The following function should be added to eutils.eclass (see bug #143572):
-
-# Generate an standard error message for missing USE flags
-# in existing packages, and die.
-#
-# Usage: built_with_use_die <category/package> <functionality> [<USE flag>]
-# ex: built_with_use_die dev-util/subversion python
-# or: built_with_use_die www-servers/apache LDAP ldap
-#
-# Typical usage:
-# if ! built_with_use dev-util/subversion python ; then
-# built_with_use_die dev-util/subversion python
-# fi
-#
-# Note: when <USE flag> is not specified, <functionality> is used for the USE flag name.
built_with_use_die() {
local package=$1
local func=$2
@@ -99,9 +78,6 @@ built_with_use_die() {
die "${package} missing ${func} support"
}
-#src_prepare(){
-# epatch ${FILESDIR}/*.patch
-#}
pkg_setup() {
webapp_pkg_setup
@@ -129,8 +105,8 @@ pkg_setup() {
built_with_use_die dev-vcs/subversion python
fi
- enewgroup tracd
- enewuser tracd -1 -1 -1 tracd
+# enewgroup tracd
+# enewuser tracd -1 -1 -1 tracd
}
src_upack(){