summaryrefslogtreecommitdiff
path: root/ekhtml/testsuite/Makefile.am
diff options
context:
space:
mode:
authoradmin@progandy.co.cc <admin@progandy.co.cc@eced67a3-f377-a0ae-92ae-d6de1850b05a>2010-09-13 18:11:13 +0000
committeradmin@progandy.co.cc <admin@progandy.co.cc@eced67a3-f377-a0ae-92ae-d6de1850b05a>2010-09-13 18:11:13 +0000
commit376594ac1d65cbb31165f5a74775d624c3fd2981 (patch)
treeb1f9bf2ee2f1a82c5d9378c03cf09f72535c001d /ekhtml/testsuite/Makefile.am
parent99ef7f1cfcaa4ead4b860faec88754abbe31ebfc (diff)
- added basic html conversion for receiving (maybe a bit too powerful)
- some bugfixes git-svn-id: http://mirotr.googlecode.com/svn/trunk@12 eced67a3-f377-a0ae-92ae-d6de1850b05a
Diffstat (limited to 'ekhtml/testsuite/Makefile.am')
-rw-r--r--ekhtml/testsuite/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/ekhtml/testsuite/Makefile.am b/ekhtml/testsuite/Makefile.am
new file mode 100644
index 0000000..adbda98
--- /dev/null
+++ b/ekhtml/testsuite/Makefile.am
@@ -0,0 +1,26 @@
+EKHTML_LIB = $(top_srcdir)/src/libekhtml.la
+
+EXTRA_DIST = \
+ ek_sgmllib.py \
+ gen_html.py \
+ plparser.pl \
+ pyparser.py \
+ test_basic.sh \
+ test_bogus_feedsize.sh \
+ test_crazypage.sh \
+ tstpages
+
+noinst_PROGRAMS = tester
+
+tester_SOURCES = tester.c
+tester_LDADD = $(EKHTML_LIB)
+tester_LDFLAGS = -static
+tester_DEPENDENCIES = $(EKHTML_LIB)
+
+$(EKHTML_LIB):
+ cd $(top_srcdir)/src && $(MAKE)
+
+TESTS = test_basic.sh test_crazypage.sh test_bogus_feedsize.sh
+
+dist-hook:
+ rm -rf `find $(distdir)/tstpages -name CVS`