summaryrefslogtreecommitdiff
path: root/libgpg-error-1.9/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libgpg-error-1.9/tests/Makefile.am')
-rw-r--r--libgpg-error-1.9/tests/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/libgpg-error-1.9/tests/Makefile.am b/libgpg-error-1.9/tests/Makefile.am
new file mode 100644
index 0000000..be63260
--- /dev/null
+++ b/libgpg-error-1.9/tests/Makefile.am
@@ -0,0 +1,35 @@
+# Makefile.am for libgpg-error/tests.
+# Copyright (C) 2003 g10 Code GmbH
+#
+# This file is part of libgpg-error.
+#
+# libgpg-error is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2.1 of the
+# License, or (at your option) any later version.
+#
+# libgpg-error is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with this program; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
+
+## Process this file with automake to produce Makefile.in
+
+if HAVE_W32CE_SYSTEM
+extra_includes = -idirafter $(top_builddir)/src/gpg-extra
+else
+extra_includes =
+endif
+
+
+TESTS = t-strerror t-syserror
+
+INCLUDES = -I$(top_builddir)/src $(extra_includes)
+
+LDADD = ../src/libgpg-error.la
+
+noinst_PROGRAMS = $(TESTS)