summaryrefslogtreecommitdiff
path: root/protocols/Discord/CMakeLists.txt
diff options
context:
space:
mode:
authorVitaly Svyastyn <protomors@gmail.com>2017-11-05 19:33:01 +0600
committerGeorge Hazan <ghazan@miranda.im>2017-11-05 16:33:01 +0300
commit52921a9e13484319df2d4f1153521f3f5e12b932 (patch)
tree5c6b99a6e59958778ab1cdfa61a0848d3211eb0a /protocols/Discord/CMakeLists.txt
parentdb6f3932affcc9397c9fbed99d344388a585add5 (diff)
More CMake (#1016)
* Generate version information before build. * Removed /EHsc from compile options. * CMake files for the rest of protocols. * CMake 64 bit build. * CMake: precompiled headers.
Diffstat (limited to 'protocols/Discord/CMakeLists.txt')
-rw-r--r--protocols/Discord/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/protocols/Discord/CMakeLists.txt b/protocols/Discord/CMakeLists.txt
new file mode 100644
index 0000000000..a227eff6df
--- /dev/null
+++ b/protocols/Discord/CMakeLists.txt
@@ -0,0 +1,5 @@
+file(GLOB SOURCES "src/*.h" "src/*.cpp" "res/*.rc")
+set(TARGET Discord)
+include(${CMAKE_SOURCE_DIR}/cmake/plugin.cmake)
+target_link_libraries(${TARGET} Zlib libjson)
+add_subdirectory(proto_discord) \ No newline at end of file