summaryrefslogtreecommitdiff
path: root/protocols/Facebook/CMakeLists.txt
diff options
context:
space:
mode:
authorGeorge Hazan <ghazan@miranda.im>2019-06-14 12:57:54 +0300
committerGeorge Hazan <ghazan@miranda.im>2019-06-14 12:57:54 +0300
commit313ab14bd5e61167b871cfada90567c156fa65eb (patch)
treec105467871f138f3ab046db102d47557d75b4705 /protocols/Facebook/CMakeLists.txt
parent339c8817ecda334f3f7af41df07a6e7bdce8824a (diff)
new Facebook plugin: very first version
Diffstat (limited to 'protocols/Facebook/CMakeLists.txt')
-rw-r--r--protocols/Facebook/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/protocols/Facebook/CMakeLists.txt b/protocols/Facebook/CMakeLists.txt
new file mode 100644
index 0000000000..6441c53332
--- /dev/null
+++ b/protocols/Facebook/CMakeLists.txt
@@ -0,0 +1,5 @@
+file(GLOB SOURCES "src/*.h" "src/requests/*.h" "src/*.cpp" "res/*.rc" "${CMAKE_SOURCE_DIR}/utils/std_string_utils.cpp")
+set(TARGET Facebook)
+include(${CMAKE_SOURCE_DIR}/cmake/plugin.cmake)
+target_link_libraries(${TARGET} libjson)
+add_subdirectory(proto_facebook) \ No newline at end of file