summaryrefslogtreecommitdiff
path: root/libs/libaxolotl/src/protobuf-c/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libs/libaxolotl/src/protobuf-c/CMakeLists.txt')
-rw-r--r--libs/libaxolotl/src/protobuf-c/CMakeLists.txt25
1 files changed, 0 insertions, 25 deletions
diff --git a/libs/libaxolotl/src/protobuf-c/CMakeLists.txt b/libs/libaxolotl/src/protobuf-c/CMakeLists.txt
deleted file mode 100644
index 1af25df194..0000000000
--- a/libs/libaxolotl/src/protobuf-c/CMakeLists.txt
+++ /dev/null
@@ -1,25 +0,0 @@
-IF(CMAKE_COMPILER_IS_GNUCC OR CMAKE_C_COMPILER_ID MATCHES "Clang")
- SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-shadow")
-ENDIF(CMAKE_COMPILER_IS_GNUCC OR CMAKE_C_COMPILER_ID MATCHES "Clang")
-
-IF(CMAKE_COMPILER_IS_GNUCC)
- SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-sign-compare")
- IF(GCC_WARN_SIGN_CONVERSION)
- SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-sign-conversion")
- ENDIF(GCC_WARN_SIGN_CONVERSION)
-ENDIF(CMAKE_COMPILER_IS_GNUCC)
-
-IF(CMAKE_C_COMPILER_ID MATCHES "Clang")
- SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-shorten-64-to-32")
-ENDIF(CMAKE_C_COMPILER_ID MATCHES "Clang")
-
-set(protobuf_SRCS
- protobuf-c.c
-)
-
-add_library(protobuf-c OBJECT ${protobuf_SRCS})
-
-# Add -fPIC flag
-if(BUILD_SHARED_LIBS)
- set_property(TARGET protobuf-c PROPERTY POSITION_INDEPENDENT_CODE ON)
-endif()