summaryrefslogtreecommitdiff
path: root/src/mir_app/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/mir_app/CMakeLists.txt')
-rw-r--r--src/mir_app/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/src/mir_app/CMakeLists.txt b/src/mir_app/CMakeLists.txt
new file mode 100644
index 0000000000..8e72c06f59
--- /dev/null
+++ b/src/mir_app/CMakeLists.txt
@@ -0,0 +1,6 @@
+file(GLOB SOURCES "src/*.h" "src/*.cpp" "src/mir_app.def" "res/*.rc")
+set(TARGET mir_app)
+include(${CMAKE_SOURCE_DIR}/cmake/lib.cmake)
+
+set_target_properties(${TARGET} PROPERTIES COMPILE_DEFINITIONS "MIR_APP_EXPORTS")
+target_link_libraries(${TARGET} Zlib) \ No newline at end of file