summaryrefslogtreecommitdiff
path: root/app-misc/g15daemon/g15daemon-9999.ebuild
diff options
context:
space:
mode:
authorGluzskiy Alexandr <sss123next@list.ru>2010-09-16 16:10:41 +0300
committerGluzskiy Alexandr <sss123next@list.ru>2010-09-16 16:10:41 +0300
commitfc0cde0e2a18d234bcea5b396ff61761cbc6560c (patch)
treecdd2214d8d449bd711bb2490f1571bfb38e03e11 /app-misc/g15daemon/g15daemon-9999.ebuild
parent5765bac9095a12ee28525fec1036ad926827b93b (diff)
quick and dirty ebuilds for my new keyboard (cource live from source repo)
Diffstat (limited to 'app-misc/g15daemon/g15daemon-9999.ebuild')
-rw-r--r--app-misc/g15daemon/g15daemon-9999.ebuild158
1 files changed, 158 insertions, 0 deletions
diff --git a/app-misc/g15daemon/g15daemon-9999.ebuild b/app-misc/g15daemon/g15daemon-9999.ebuild
new file mode 100644
index 0000000..4b585c1
--- /dev/null
+++ b/app-misc/g15daemon/g15daemon-9999.ebuild
@@ -0,0 +1,158 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-1.9.5.3-r3.ebuild,v 1.6 2010/05/29 21:11:59 arfrever Exp $
+
+EAPI=2
+
+inherit eutils linux-info perl-module python multilib base subversion autotools
+
+DESCRIPTION="G15daemon takes control of the G15 keyboard, through the linux kernel uinput device driver"
+HOMEPAGE="http://g15daemon.sourceforge.net/"
+ESVN_REPO_URI="https://g15daemon.svn.sourceforge.net/svnroot/g15daemon/trunk/g15daemon-wip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="perl python"
+
+DEPEND="=virtual/libusb-0*
+ >=dev-libs/libg15-1.2.4
+ >=dev-libs/libg15render-1.2
+ perl? ( >=dev-perl/Inline-0.4 )
+ python? ( dev-lang/python )"
+
+RDEPEND="${DEPEND}
+ perl? ( dev-perl/GDGraph )"
+
+uinput_check() {
+ ebegin "Checking for uinput support"
+ local rc=1
+ linux_config_exists && linux_chkconfig_present INPUT_UINPUT
+ rc=$?
+
+ if [[ $rc -ne 0 ]] ; then
+ eerror "To use g15daemon, you need to compile your kernel with uinput support."
+ eerror "Please enable uinput support in your kernel config, found at:"
+ eerror
+ eerror "Device Drivers -> Input Device ... -> Miscellaneous devices -> User level driver support."
+ eerror
+ eerror "Once enabled, you should have the /dev/input/uinput device."
+ eerror "g15daemon will not work without the uinput device."
+ fi
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+ uinput_check
+}
+
+src_unpack() {
+ subversion_src_unpack
+ if use perl; then
+ unpack "./lang-bindings/perl-G15Daemon-0.2.tar.gz"
+ fi
+ if use python; then
+ unpack "./lang-bindings/pyg15daemon-0.0.tar.bz2"
+ fi
+}
+
+src_prepare() {
+ if use perl; then
+ perl-module_src_prepare
+ sed -i \
+ -e '1i#!/usr/bin/perl' \
+ "${S}"/contrib/testbindings.pl
+ else
+ # perl-module_src_prepare always calls base_src_prepare
+ base_src_prepare
+ fi
+}
+
+src_configure() {
+ eautoreconf
+ econf
+ emake || die "make failed"
+
+ if use perl; then
+ cd "${WORKDIR}/g15daemon-9999/G15Daemon-0.2"
+ perl-module_src_configure
+ fi
+}
+
+src_compile() {
+ base_src_compile
+
+ if use perl; then
+ cd "${WORKDIR}/G15Daemon-0.2"
+ perl-module_src_compile
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ docdir=/usr/share/doc/${PF} install || die "make install failed"
+
+ # remove odd docs installed my make
+ rm "${D}/usr/share/doc/${PF}/"{LICENSE,README.usage}
+
+ insinto /usr/share/${PN}/contrib
+ doins contrib/xmodmaprc
+ doins contrib/xmodmap.sh
+ if use perl; then
+ doins contrib/testbindings.pl
+ fi
+
+ newconfd "${FILESDIR}/${PN}.confd" ${PN}
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+ dobin "${FILESDIR}/g15daemon-hotplug"
+ insinto /etc/udev/rules.d
+ doins "${FILESDIR}/99-g15daemon.rules"
+
+ insinto /etc
+ doins "${FILESDIR}"/g15daemon.conf
+
+ if use perl; then
+ ebegin "Installing Perl Bindings (G15Daemon.pm)"
+ cd "${WORKDIR}/g15daemon-9999/G15Daemon-0.2"
+ docinto perl
+ perl-module_src_install
+ fi
+
+ if use python; then
+ ebegin "Installing Python Bindings (g15daemon.py)"
+ cd "${WORKDIR}/g15daemon-9999/pyg15daemon"
+
+ insinto $(python_get_sitedir)/g15daemon
+ doins g15daemon.py
+
+ docinto python
+ dodoc AUTHORS
+ fi
+}
+
+pkg_postinst() {
+ if use python; then
+ python_mod_optimize $(python_get_sitedir)/g15daemon
+ echo ""
+ fi
+
+ elog "To use g15daemon, you need to add g15daemon to the default runlevel."
+ elog "This can be done with:"
+ elog "# /sbin/rc-update add g15daemon default"
+ elog "You can edit some g15daemon options at /etc/conf.d/g15daemon"
+ elog ""
+ elog "To have all new keys working in X11, you'll need create a "
+ elog "specific xmodmap in your home directory or edit the existent one."
+ elog ""
+ elog "Create the xmodmap:"
+ elog "cp /usr/share/g15daemon/contrib/xmodmaprc ~/.Xmodmap"
+ elog ""
+ elog "Adding keycodes to an existing xmodmap:"
+ elog "cat /usr/share/g15daemon/contrib/xmodmaprc >> ~/.Xmodmap"
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup $(python_get_sitedir)/g15daemon
+ fi
+}