summaryrefslogtreecommitdiff
path: root/app-misc/mc/files/mc.gentoo
diff options
context:
space:
mode:
authorroot <root@evil.(none)>2009-06-10 01:24:48 +0300
committerroot <root@evil.(none)>2009-06-10 01:24:48 +0300
commitc8f9ea324922b8264726938021e3dafc1d1c42d0 (patch)
tree7ef3dd3d27e3211fe39e24346c2a0609fae15b74 /app-misc/mc/files/mc.gentoo
parent04165476be4a4d33ced17c20fcb0b97f30c0910c (diff)
new file: app-misc/mc/mc-4.9999.ebuild (Midnight Commander from git)
new file: net-dialup/openl2tp/openl2tp-1.4.ebuild (openl2tp)
Diffstat (limited to 'app-misc/mc/files/mc.gentoo')
-rw-r--r--app-misc/mc/files/mc.gentoo16
1 files changed, 16 insertions, 0 deletions
diff --git a/app-misc/mc/files/mc.gentoo b/app-misc/mc/files/mc.gentoo
new file mode 100644
index 0000000..a71d249
--- /dev/null
+++ b/app-misc/mc/files/mc.gentoo
@@ -0,0 +1,16 @@
+#!/bin/sh
+
+# A little fix so mc exits into it's current working directory
+MC_ENV=/usr/share/mc/bin/mc.sh
+
+for i in $MC_ENV; do
+ if [ -x $i ]; then
+ . $i
+ fi
+done
+
+# include this, so also xterm,kterm,gterm,etc will have default bash settings
+
+#if [ "x$SHLVL" != "x1" ]; then # We're not a login shell
+# . /etc/profile
+#fi