summaryrefslogtreecommitdiff
path: root/dev-libs/protobuf-c/protobuf-c-scm.ebuild
diff options
context:
space:
mode:
authorGluzskiy Alexandr <sss123next@list.ru>2014-11-29 16:11:45 +0300
committerGluzskiy Alexandr <sss123next@list.ru>2014-11-29 16:11:45 +0300
commitdeffdcda966ac6a929c93439a18a981cd26770ce (patch)
tree13bbe07efc4d329e7b7858fd833776878f90ad57 /dev-libs/protobuf-c/protobuf-c-scm.ebuild
parent7971aea8a3e0dcc795db6573b605a0ee100a9058 (diff)
criu
Diffstat (limited to 'dev-libs/protobuf-c/protobuf-c-scm.ebuild')
-rw-r--r--dev-libs/protobuf-c/protobuf-c-scm.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-libs/protobuf-c/protobuf-c-scm.ebuild b/dev-libs/protobuf-c/protobuf-c-scm.ebuild
new file mode 100644
index 0000000..09cfb9c
--- /dev/null
+++ b/dev-libs/protobuf-c/protobuf-c-scm.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/protobuf-c/protobuf-c-1.0.2-r1.ebuild,v 1.1 2014/11/27 18:22:22 radhermit Exp $
+
+EAPI=5
+
+inherit autotools-multilib git-2
+
+EGIT_REPO_URI="https://github.com/protobuf-c/protobuf-c.git"
+EGIT_BOOTSTRAP="./autogen.sh"
+
+
+DESCRIPTION="code generator and runtime libraries to use Protocol Buffers (protobuf) from pure C"
+HOMEPAGE="https://github.com/protobuf-c/protobuf-c/"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="static-libs"
+
+RDEPEND=">=dev-libs/protobuf-2.5.0-r2[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig[${MULTILIB_USEDEP}]"
+