summaryrefslogtreecommitdiff
path: root/dev-qt/qtwebchannel/qtwebchannel-5.10.9999.ebuild
diff options
context:
space:
mode:
authorGluzskiy Alexandr <sss@sss.chaoslab.ru>2018-02-23 16:00:56 +0300
committerGluzskiy Alexandr <sss@sss.chaoslab.ru>2018-02-23 16:00:56 +0300
commit57c8c6a8613ffe1e96587e21b34249133e54e4d2 (patch)
treea95832bfa28a57a4dd7df2a86fc33a19d98fe4cc /dev-qt/qtwebchannel/qtwebchannel-5.10.9999.ebuild
parentabbc99af90c96d4f50084e29633b32594b9bbfec (diff)
qt 5.10 scm from qt repo
Diffstat (limited to 'dev-qt/qtwebchannel/qtwebchannel-5.10.9999.ebuild')
-rw-r--r--dev-qt/qtwebchannel/qtwebchannel-5.10.9999.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-qt/qtwebchannel/qtwebchannel-5.10.9999.ebuild b/dev-qt/qtwebchannel/qtwebchannel-5.10.9999.ebuild
new file mode 100644
index 0000000..63c52e4
--- /dev/null
+++ b/dev-qt/qtwebchannel/qtwebchannel-5.10.9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="Qt5 module for integrating C++ and QML applications with HTML/JavaScript clients"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+IUSE="qml"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ qml? ( ~dev-qt/qtdeclarative-${PV} )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ qt_use_disable_mod qml quick src/src.pro
+ qt_use_disable_mod qml qml src/webchannel/webchannel.pro
+
+ qt5-build_src_prepare
+}