summaryrefslogtreecommitdiff
path: root/games-emulation/gelide/gelide-9999.ebuild
diff options
context:
space:
mode:
authorGluzskiy Alexandr <sss123next@list.ru>2013-01-09 03:46:32 +0200
committerGluzskiy Alexandr <sss123next@list.ru>2013-01-09 03:46:32 +0200
commit7051b0e1e3b78762f929d465c820430d1a72534c (patch)
treebdb34f692f917cec49689bb78804584bdc10bb0e /games-emulation/gelide/gelide-9999.ebuild
parentc8f90a714cc0ebc5360d6be8bf17fcbfb421bd92 (diff)
new file: gelide/files/gelide-0.1.5-build.patch
new file: gelide/files/glib.patch new file: gelide/gelide-9999.ebuild
Diffstat (limited to 'games-emulation/gelide/gelide-9999.ebuild')
-rw-r--r--games-emulation/gelide/gelide-9999.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/games-emulation/gelide/gelide-9999.ebuild b/games-emulation/gelide/gelide-9999.ebuild
new file mode 100644
index 0000000..1a4f430
--- /dev/null
+++ b/games-emulation/gelide/gelide-9999.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=2
+
+inherit games git-2
+
+DESCRIPTION="A flexible frontend for video game emulators"
+HOMEPAGE="http://gelide.sourceforge.net/"
+SRC_URI=""
+
+EGIT_REPO_URI="git://${PN}.git.sourceforge.net/gitroot/${PN}/${PN}"
+EGIT_BOOTSTRAP="autogen.sh"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE="debug nls scrollkeeper"
+
+RDEPEND="app-text/gnome-doc-utils
+ dev-cpp/gtkmm
+ dev-libs/libxml2
+ dev-util/intltool
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )
+ scrollkeeper? ( app-text/scrollkeeper )"
+
+src_prepare() {
+ # Apply ugly patch to filter out hardcoded extensions
+ #epatch "${FILESDIR}/extfilter.patch"
+ epatch "${FILESDIR}/glib.patch"
+
+ # Set emulator paths to gentoo default
+ sed -e "s;l_emulator\.setPath(\"[/a-z]*/;l_emulator\.setPath(\"${GAMES_BINDIR}/;" \
+ -i "${S}/src/core/default_systems.cpp" || die "sed failed"
+}
+
+src_configure() {
+ egamesconf \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable scrollkeeper) \
+ --docdir=/usr/share/doc/${PF} \
+ --localedir=/usr/share/locale \
+ --disable-dependency-tracking \
+ --datadir=/usr/share \
+ || die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS COPYING ChangeLog NEWS README doc/*.txt
+
+ prepgamesdirs
+}