summaryrefslogtreecommitdiff
path: root/games-emulation/ps2emu-peopsspu2/ps2emu-peopsspu2-9999.ebuild
diff options
context:
space:
mode:
author(no author) <(no author)@4d9a9b59-111c-4e0b-8f7a-7640551abb98>2009-03-16 07:55:01 +0000
committer(no author) <(no author)@4d9a9b59-111c-4e0b-8f7a-7640551abb98>2009-03-16 07:55:01 +0000
commitf1e95daae05c57d935b00e611c624c5e75cd21ec (patch)
tree4065ab51d9e64882d9001a59ede7d9a4e372a4a6 /games-emulation/ps2emu-peopsspu2/ps2emu-peopsspu2-9999.ebuild
uploading my overlay ), initial commit
git-svn-id: http://172.18.13.13/svn/sss_overlay@1 4d9a9b59-111c-4e0b-8f7a-7640551abb98
Diffstat (limited to 'games-emulation/ps2emu-peopsspu2/ps2emu-peopsspu2-9999.ebuild')
-rw-r--r--games-emulation/ps2emu-peopsspu2/ps2emu-peopsspu2-9999.ebuild65
1 files changed, 65 insertions, 0 deletions
diff --git a/games-emulation/ps2emu-peopsspu2/ps2emu-peopsspu2-9999.ebuild b/games-emulation/ps2emu-peopsspu2/ps2emu-peopsspu2-9999.ebuild
new file mode 100644
index 0000000..3dc0589
--- /dev/null
+++ b/games-emulation/ps2emu-peopsspu2/ps2emu-peopsspu2-9999.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+ESVN_REPO_URI="https://pcsx2.svn.sourceforge.net/svnroot/pcsx2/plugins/spu2/PeopsSPU2"
+inherit eutils games subversion
+
+DESCRIPTION="P.E.Op.S PS2Emu sound plugin"
+HOMEPAGE="http://www.pcsx2.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="alsa oss"
+
+DEPEND="alsa? ( media-libs/alsa-lib )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/PeopsSPU2"
+
+pkg_setup() {
+ if ! use oss && ! use alsa; then
+ die "Either the alsa or oss USE flag must be enabled!"
+ fi
+}
+
+src_unpack() {
+ subversion_src_unpack
+ cd "${S}"
+
+ sed -i \
+ -e '/^CC =/d' \
+ -e '/\bstrip\b/d' \
+ -e 's/-O[0-9]\b//g' \
+ -e 's/-fomit-frame-pointer\b//g' \
+ -e 's/-ffast-math\b//g' \
+ -e 's/CCFLAGS3 =/CCFLAGS3 = $(CFLAGS)/' \
+ Makefile || die
+}
+
+src_compile() {
+ if use oss; then
+ sed -i 's/USEALSA = .*$/USEALSA = FALSE/' Makefile
+ emake || die
+ fi
+
+ if use alsa; then
+ sed -i 's/USEALSA = .*$/USEALSA = TRUE/' Makefile
+ emake || die
+ fi
+}
+
+src_install() {
+ exeinto "$(games_get_libdir)/ps2emu/plugins"
+
+ if use oss; then
+ doexe libspu2PeopsOSS.so.* || die
+ fi
+
+ if use alsa; then
+ doexe libspu2PeopsALSA.so.*|| die
+ fi
+
+ prepgamesdirs
+}