summaryrefslogtreecommitdiff
path: root/media-libs/mesa/mesa-scm.ebuild
diff options
context:
space:
mode:
authorGluzskiy Alexandr <sss123next@list.ru>2015-08-21 14:36:58 +0300
committerGluzskiy Alexandr <sss123next@list.ru>2015-08-21 14:36:58 +0300
commita843a0c850311d4a11e5b4119f9e8269b8b59a63 (patch)
tree264edafc66f61bb5941b955a6c59772d5df7d896 /media-libs/mesa/mesa-scm.ebuild
parent2b57359acd40a2e9956e3ef32cddb388ad880a11 (diff)
cleanup
Diffstat (limited to 'media-libs/mesa/mesa-scm.ebuild')
-rw-r--r--media-libs/mesa/mesa-scm.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/media-libs/mesa/mesa-scm.ebuild b/media-libs/mesa/mesa-scm.ebuild
index d655759..697ceb6 100644
--- a/media-libs/mesa/mesa-scm.ebuild
+++ b/media-libs/mesa/mesa-scm.ebuild
@@ -5,11 +5,7 @@
EAPI=5
-if use nine-branch; then
- EGIT_REPO_URI="https://github.com/iXit/Mesa-3D.git"
-else
- EGIT_REPO_URI="http://anongit.freedesktop.org/git/mesa/mesa"
-fi
+EGIT_REPO_URI="http://anongit.freedesktop.org/git/mesa/mesa"
GIT_ECLASS="git-r3"
EXPERIMENTAL="true"
@@ -47,12 +43,12 @@ for card in ${VIDEO_CARDS}; do
done
IUSE="${IUSE_VIDEO_CARDS}
- bindist +classic d3d9 debug +dri3 +egl +gallium +gbm gles1 gles2 +llvm
+ bindist +classic d3d debug +dri3 +egl +gallium +gbm gles1 gles2 +llvm
+nptl opencl osmesa pax_kernel openmax pic r600-llvm-compiler selinux
- vaapi vdpau wayland xvmc xa nine-branch kernel_FreeBSD"
+ vaapi vdpau wayland xvmc xa kernel_FreeBSD"
REQUIRED_USE="
- d3d9? ( gallium )
+ d3d? ( gallium )
llvm? ( gallium )
opencl? (
gallium
@@ -243,7 +239,7 @@ multilib_src_configure() {
if use gallium; then
myconf+="
- $(use_enable d3d9 nine)
+ $(use_enable d3d nine)
$(use_enable llvm gallium-llvm)
$(use_enable openmax omx)
$(use_enable r600-llvm-compiler)
@@ -301,7 +297,7 @@ multilib_src_configure() {
--enable-glx \
--enable-shared-glapi \
$(use_enable !bindist texture-float) \
- $(use_enable d3d9 nine) \
+ $(use_enable d3d nine) \
$(use_enable debug) \
$(use_enable dri3) \
$(use_enable egl) \