summaryrefslogtreecommitdiff
path: root/net-libs/stem/stem-scm.ebuild
diff options
context:
space:
mode:
authorGluzskiy Alexandr <sss123next@list.ru>2016-08-30 19:08:08 +0300
committerGluzskiy Alexandr <sss123next@list.ru>2016-08-30 19:08:08 +0300
commite9220842cf145ec49bb70fa986e627ba5b85bc8f (patch)
tree1a5363d731ac73d6fd114112dd5257f170d24c00 /net-libs/stem/stem-scm.ebuild
parenta3a213f6728942c5c33025bfae9e11bb3c29cdd3 (diff)
added nyx (old name arm) - tor cli tool
Diffstat (limited to 'net-libs/stem/stem-scm.ebuild')
-rw-r--r--net-libs/stem/stem-scm.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-libs/stem/stem-scm.ebuild b/net-libs/stem/stem-scm.ebuild
new file mode 100644
index 0000000..d80f601
--- /dev/null
+++ b/net-libs/stem/stem-scm.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
+
+inherit vcs-snapshot distutils-r1 git-r3
+
+DESCRIPTION="Stem is a Python controller library for Tor"
+HOMEPAGE="https://stem.torproject.org"
+SRC_URI=""
+EGIT_REPO_URI="https://git.torproject.org/stem.git"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+DEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}]
+ net-misc/tor )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="net-misc/tor"
+
+DOCS=( docs/{_static,_templates,api,tutorials,{change_log,api,contents,download,faq,index,tutorials}.rst} )
+
+python_prepare_all() {
+ # Disable failing test
+# sed -i -e "/test_expand_path/a \
+# \ \ \ \ return" test/integ/util/system.py || die
+# sed -i -e "/test_get_connections_by_ss/,+1d"\
+# test/integ/util/connection.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ${PYTHON} run_tests.py --all --target RUN_ALL || die
+}