summaryrefslogtreecommitdiff
path: root/app-emulation/lxc/lxc-scm.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/lxc/lxc-scm.ebuild')
-rw-r--r--app-emulation/lxc/lxc-scm.ebuild34
1 files changed, 16 insertions, 18 deletions
diff --git a/app-emulation/lxc/lxc-scm.ebuild b/app-emulation/lxc/lxc-scm.ebuild
index ee656f7..2c289e1 100644
--- a/app-emulation/lxc/lxc-scm.ebuild
+++ b/app-emulation/lxc/lxc-scm.ebuild
@@ -106,8 +106,6 @@ pkg_setup() {
}
src_prepare() {
- eapply "${FILESDIR}"/${P}-bash-completion.patch
- #558854
eapply "${FILESDIR}"/${PN}-2.0.5-omit-sysconfig.patch
# eapply "${FILESDIR}"/${PN}-2.0.6-major.patch
eapply_user
@@ -143,36 +141,36 @@ src_configure() {
$(use_enable seccomp)
}
-python_compile() {
- distutils-r1_python_compile build_ext -I ../ -L ../${PN}
-}
+#python_compile() {
+# distutils-r1_python_compile build_ext -I ../ -L ../${PN}
+#}
src_compile() {
default
- if use python; then
- pushd "${S}/src/python-${PN}" > /dev/null
- distutils-r1_src_compile
- popd > /dev/null
- fi
+# if use python; then
+# pushd "${S}/src/python-${PN}" > /dev/null
+# distutils-r1_src_compile
+# popd > /dev/null
+# fi
}
src_install() {
default
- mv "${ED}"/usr/share/bash-completion/completions/${PN} "${ED}"/$(get_bashcompdir)/${PN}-start || die
+# mv "${ED}"/usr/share/bash-completion/completions/${PN} "${ED}"/$(get_bashcompdir)/${PN}-start || die
# start-ephemeral is no longer a command but removing it here
# generates QA warnings (still in upstream completion script)
bashcomp_alias ${PN}-start \
${PN}-{attach,cgroup,copy,console,create,destroy,device,execute,freeze,info,monitor,snapshot,start-ephemeral,stop,unfreeze,wait}
- if use python; then
- pushd "${S}/src/python-lxc" > /dev/null
- # Unset DOCS. This has been handled by the default target
- unset DOCS
- distutils-r1_src_install
- popd > /dev/null
- fi
+# if use python; then
+# pushd "${S}/src/python-lxc" > /dev/null
+# # Unset DOCS. This has been handled by the default target
+# unset DOCS
+# distutils-r1_src_install
+# popd > /dev/null
+# fi
keepdir /etc/lxc /var/lib/lxc/rootfs /var/log/lxc