summaryrefslogtreecommitdiff
path: root/dev-games/crystalspace-ps/crystalspace-ps-1.9-r35804.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/crystalspace-ps/crystalspace-ps-1.9-r35804.ebuild')
-rw-r--r--dev-games/crystalspace-ps/crystalspace-ps-1.9-r35804.ebuild125
1 files changed, 0 insertions, 125 deletions
diff --git a/dev-games/crystalspace-ps/crystalspace-ps-1.9-r35804.ebuild b/dev-games/crystalspace-ps/crystalspace-ps-1.9-r35804.ebuild
deleted file mode 100644
index 5d3a885..0000000
--- a/dev-games/crystalspace-ps/crystalspace-ps-1.9-r35804.ebuild
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/crystalspace-ps/crystalspace-ps-1.9-r35803.ebuild,v 1.9 2011/02/18 12:00:00 loux.thefuture Exp $
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Portable 3D Game Development Kit written in C++"
-HOMEPAGE="http://crystal.sourceforge.net/"
-SRC_URI="http://dev.gentooexperimental.org/~loux/distfiles/crystalspace-ps-1.9-r35803.tar.bz2
- http://loux.thefuture.free.fr/distfiles/crystalspace-ps-1.9-r35803.tar.bz2"
-LICENSE="LGPL-2.1"
-SLOT="2"
-KEYWORDS=" ~x86 ~amd64"
-IUSE="alsa cegui mng ode sdl static maxoptimization doc debug multislot cairo"
-#to test IUSE="python"
-RESTRICT="mirror"
-
-RDEPEND="virtual/opengl
- media-libs/freeglut
- cegui? ( >=dev-games/cegui-0.5 )
- ode? ( dev-games/ode )
- media-libs/libogg
- media-libs/libvorbis
- alsa? ( media-libs/alsa-lib )
- mng? ( media-libs/libmng )
- cairo? ( x11-libs/cairo )
- virtual/jpeg
- x11-libs/libXaw
- x11-libs/libXxf86vm
- >=media-gfx/nvidia-cg-toolkit-2.2.0
- >=media-libs/cal3d-0.12
- >=media-libs/freetype-2.1
- media-libs/libpng
- media-libs/openal
- media-libs/freealut
- media-libs/speex
-"
-
-DEPEND="${RDEPEND}
- dev-util/ftjam"
-
-#to test python? ( dev-lang/swig )
-
-S="${WORKDIR}/crystal"
-CS_PREFIX="/opt/planeshift/crystalspace-1.9"
-
-src_compile() {
- my_conf=""
- if use maxoptimization && ! use debug ; then
- my_conf="--enable-cpu-specific-optimizations=maximum"
- else
- my_conf="--enable-cpu-specific-optimizations=no"
- fi
-
- if ! use doc ; then
- sed -e 's!SubInclude TOP docs ;!!' -i Jamfile.in
- fi
-
- if use debug; then
- my_conf="${my_conf} --enable-debug"
- LDFLAGS=""
- else
- my_conf="${my_conf} --enable-separate-debug-info=no"
- fi
-
- #for cg : media-gfx/nvidia-cg-toolkit
- my_conf="${my_conf} --with-Cg=/opt/nvidia-cg-toolkit"
- my_conf="${my_conf} --with-CgGL=/opt/nvidia-cg-toolkit"
-
- #force le crash du test v9 sparc
- sed 's/mcpu=v9/mcpu-bad=v9/g' -i configure
-
- econf --prefix=${CS_PREFIX} \
- --datadir=${CS_PREFIX}/share \
- --sysconfdir=${CS_PREFIX}/etc \
- --infodir=${CS_PREFIX}/share/info \
- --mandir=${CS_PREFIX}/share/man \
- ${my_conf} \
- --without-lcms \
- --without-java \
- --without-wx \
- --with-png \
- --with-freetype2 \
- --with-cal3d \
- --with-jpeg \
- --with-speex \
- $(use_with cairo) \
- $(use_with mng) \
- $(use_with ode) \
- $(use_with cegui CEGUI) \
- $(use_with alsa asound) \
- --without-python
- #$(use_with python)
-
- #jam ${MAKEOPTS} || die "compile failed"
- jam || die "compile failed"
- if use static ; then
- jam ${MAKEOPTS} staticplugins || die "compile staticplugins failed"
- fi
-}
-
-src_install() {
- jam -q -s DESTDIR="${D}" install || die "make install failed"
- MY_LIB="lib"
- if use amd64 ; then
- dosym ${CS_PREFIX}/lib64 ${CS_PREFIX}/lib
- MY_LIB="lib64"
- fi
- dosym libcrystalspace-1.9.a ${CS_PREFIX}/${MY_LIB}/libcrystalspace.a
- dosym libcrystalspace_opengl-1.9.a ${CS_PREFIX}/${MY_LIB}/libcrystalspace_opengl.a
- if use static ; then
- sed -i -e 's!Depends install_staticplugins : install_libs ;!!' \
- mk/jam/static.jam
-
- jam -q -s DESTDIR="${D}" install_staticplugins || die "make install_static_plugins failed"
- dosym libcrystalspace_staticplugins-1.9.a ${CS_PREFIX}/${MY_LIB}/libcrystalspace_staticplugins.a
- fi
- if [[ ! -e cs-config ]]; then
- dosym ${CS_PREFIX}/bin/cs-config-1.9 ${CS_PREFIX}/bin/cs-config
- fi
-
- #echo "CRYSTAL_CONFIG=${CS_PREFIX}/etc/crystalspace-1.9" > "${T}"/90crystalspace
- #echo "CRYSTAL=${CS_PREFIX}" >> "${T}"/90crystalspace
- #doenvd "${T}"/90crystalspace
-}