summaryrefslogtreecommitdiff
path: root/dev-libs/libg15/libg15-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libg15/libg15-9999.ebuild')
-rw-r--r--dev-libs/libg15/libg15-9999.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-libs/libg15/libg15-9999.ebuild b/dev-libs/libg15/libg15-9999.ebuild
new file mode 100644
index 0000000..6b15a77
--- /dev/null
+++ b/dev-libs/libg15/libg15-9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libg15/libg15-1.2.7.ebuild,v 1.4 2010/03/09 21:52:36 josejx Exp $
+
+inherit subversion autotools
+
+DESCRIPTION="The libg15 library gives low-level access to the Logitech G15 keyboard"
+HOMEPAGE="http://g15tools.sourceforge.net/"
+ESVN_REPO_URI="https://g15tools.svn.sourceforge.net/svnroot/g15tools/trunk/libg15"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+src_unpack() {
+ subversion_src_unpack
+}
+
+
+DEPEND="=virtual/libusb-0*"
+RDEPEND=${DEPEND}
+
+src_compile() {
+ eautoreconf
+ econf
+ emake DESTDIR="${D}" install || die "make install failed"
+}
+
+src_install() {
+ dolib .libs/*
+ insinto /usr/include
+ doins libg15
+ dodoc AUTHORS README ChangeLog
+}