summaryrefslogtreecommitdiff
path: root/dev-libs/ptlib/ptlib-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/ptlib/ptlib-9999.ebuild')
-rw-r--r--dev-libs/ptlib/ptlib-9999.ebuild108
1 files changed, 0 insertions, 108 deletions
diff --git a/dev-libs/ptlib/ptlib-9999.ebuild b/dev-libs/ptlib/ptlib-9999.ebuild
deleted file mode 100644
index aa08f93..0000000
--- a/dev-libs/ptlib/ptlib-9999.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="1"
-
-inherit eutils subversion autotools
-
-DESCRIPTION="Network focused portable C++ class library providing high level functions"
-HOMEPAGE="http://www.opalvoip.org/"
-SRC_URI=""
-
-ESVN_REPO_URI="https://opalvoip.svn.sourceforge.net/svnroot/opalvoip/ptlib/trunk"
-ESVN_STORE_DIR="${DISTDIR}/svn-src"
-ESVN_PROJECT="${PN/-svn}"
-#ESVN_BOOTSTRAP="./autogen.sh"
-
-S="${WORKDIR}/${P/_/}"
-
-LICENSE="MPL-1.0"
-SLOT=""
-KEYWORDS=""
-IUSE="alsa bsdvideo debug doc esd ieee1394 ipv6 ldap minimal noaudio novideo oss
-sasl sdl ssl sunaudio v4l v4l2 xml +exceptions +plugins opal"
-
-RDEPEND="alsa? ( media-libs/alsa-lib )
- esd? ( media-sound/esound )
- ieee1394? ( media-libs/libdv
- sys-libs/libavc1394
- media-libs/libdc1394:1 )
- ldap? ( net-nds/openldap )
- sasl? ( dev-libs/cyrus-sasl:2 )
- sdl? ( media-libs/libsdl )
- ssl? ( dev-libs/openssl )
- xml? ( dev-libs/expat )"
-DEPEND="${RDEPEND}
- sys-devel/bison
- sys-devel/flex
- v4l? ( sys-kernel/linux-headers )
- v4l2? ( sys-kernel/linux-headers )
- !dev-libs/pwlib"
-
-src_unpack() {
- subversion_src_unpack
- cd "${S}"
-# eautoreconf
-
- # this patch fixes bugs: #145424 and #140358
-# epatch "${FILESDIR}"/${PN}-asm.patch
-}
-
-src_compile() {
- local myconf=""
- local makeopts=""
-
- use noaudio && myconf="${myconf} --disable-audio"
- use novideo && myconf="${myconf} --disable-video"
-
- econf \
- ${myconf} \
- $(use_enable alsa) \
- $(use_enable bsdvideo) \
- $(use_enable debug exceptions) \
- $(use_enable debug memcheck) \
- $(use_enable esd) \
- $(use_enable ieee1394 avc) \
- $(use_enable ieee1394 dc) \
- $(use_enable ipv6) \
- $(use_enable ldap openldap) \
- $(use_enable minimal minsize) \
- $(use_enable oss) \
- $(use_enable sasl) \
- $(use_enable sdl) \
- $(use_enable ssl openssl) \
- $(use_enable sunaudio) \
- $(use_enable v4l) \
- $(use_enable v4l2) \
- $(use_enable xml expat) \
- $(use_enable exceptions) \
- $(use_enable plugins) \
- $(use_enable opal) \
- || die "econf failed"
-
- if use debug; then
- makeopts="${makeopts} DEBUG=1 debug"
- fi
-
- emake ${makeopts} || die "emake failed"
-}
-
-src_install() {
- local makeopts
-
- makeopts="PREFIX=/usr DESTDIR=\"${D}\""
-
- if use debug; then
- makeopts="${makeopts} DEBUG=1"
- fi
-
- emake ${makeopts} install || die "emake install failed"
-
-# if use doc; then
-# dohtml -r html/* || die "documentation installation failed"
-# fi
-
-# dodoc ReadMe.txt ReadMe_QOS.txt History.txt || die "documentation
-# installation failed"
-}