summaryrefslogtreecommitdiff
path: root/dev-python/genshi/genshi-0.6.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/genshi/genshi-0.6.9999.ebuild')
-rw-r--r--dev-python/genshi/genshi-0.6.9999.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-python/genshi/genshi-0.6.9999.ebuild b/dev-python/genshi/genshi-0.6.9999.ebuild
deleted file mode 100644
index 2403f64..0000000
--- a/dev-python/genshi/genshi-0.6.9999.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/genshi/genshi-0.5.1.ebuild,v 1.5 2008/11/16 17:46:16 maekke Exp $
-
-inherit distutils-r1 subversion
-PYTHON_COMPAT=( python{2_7,3_5} )
-MY_P="Genshi-${PV}"
-
-DESCRIPTION="Python toolkit for stream-based generation of output for the web."
-HOMEPAGE="http://genshi.edgewall.org/"
-SRC_URI=""
-
-ESVN_REPO_URI="http://svn.edgewall.org/repos/genshi/trunk"
-
-LICENSE="BSD"
-SLOT=""
-KEYWORDS="amd64 ppc ~ppc64 ~sparc x86"
-IUSE="doc examples"
-
-DEPEND="dev-python/setuptools"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- subversion_src_unpack
- cd ${S}
- rm setup.cfg
-# epatch ${FILESDIR}/version_info.patch
-}
-
-src_install() {
- distutils-r1_src_install
-
- if use doc ; then
- dodoc doc/*.txt
- dohtml -r doc/*
- fi
-
- if use examples ; then
- insinto /usr/share/doc/${PF}
- doins -r examples
- fi
-}
-
-src_test() {
- "${python}" setup.py test || die "test failed"
-}