summaryrefslogtreecommitdiff
path: root/games-arcade/tsc/tsc-scm.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/tsc/tsc-scm.ebuild')
-rw-r--r--games-arcade/tsc/tsc-scm.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/games-arcade/tsc/tsc-scm.ebuild b/games-arcade/tsc/tsc-scm.ebuild
new file mode 100644
index 0000000..5cb8fef
--- /dev/null
+++ b/games-arcade/tsc/tsc-scm.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2012 Funtoo Technologies
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/smc/smc-1.9.ebuild,v 1.5 2011/04/27 16:39:06 mr_bones_ Exp $
+
+EAPI=5
+inherit eutils flag-o-matic git-2 cmake-utils
+
+DESCRIPTION="The Secret Chronicles of Dr. M."
+HOMEPAGE="http://www.secretchronicles.de"
+EGIT_REPO_URI="git://github.com/Secretchronicles/TSC.git"
+EGIT_BRANCH="devel"
+BUILD_DIR="$WORKDIR/tsc"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="media-libs/glew
+ virtual/opengl
+ media-libs/libpng
+ media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ dev-libs/libpcre
+ dev-cpp/libxmlpp
+ media-libs/freetype
+ >=dev-libs/boost-1.50
+ media-libs/devil
+"
+DEPEND="dev-util/gperf
+ sys-devel/bison
+ dev-util/pkgconfig
+"
+
+S="${WORKDIR}/${PN}"
+
+EGIT_NOUNPACK="1"
+EGIT_SOURCEDIR="${WORKDIR}"
+
+src_unpack() {
+ git-2_src_unpack
+
+}
+
+
+src_configure() {
+# cd tsc
+ cmake-utils_src_configure
+}
+
+
+src_compile() {
+# cd tsc
+ cmake-utils_src_compile
+}
+
+
+src_install() {
+ cmake-utils_src_install
+}