summaryrefslogtreecommitdiff
path: root/games-emulation/gens/gens-2.12b.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/gens/gens-2.12b.ebuild')
-rw-r--r--games-emulation/gens/gens-2.12b.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/games-emulation/gens/gens-2.12b.ebuild b/games-emulation/gens/gens-2.12b.ebuild
deleted file mode 100644
index c81a780..0000000
--- a/games-emulation/gens/gens-2.12b.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# v-fox's private overlay: dfx.homeftp.net
-
-inherit flag-o-matic eutils games
-
-DESCRIPTION="A Sega Genesis/CD/32X emulator"
-HOMEPAGE="http://gens.consolemul.com/"
-
-SRC_URI="mirror://sourceforge/gens/gens-rc3.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 x86"
-IUSE="vanilla"
-
-RDEPEND="x86? ( >=x11-libs/gtk+-2.4
- >=media-libs/libsdl-1.2 )
- amd64? ( app-emulation/emul-linux-x86-sdl
- app-emulation/emul-linux-x86-gtklibs )"
-DEPEND="${RDEPEND}
- >=dev-lang/nasm-0.98"
-
-S=${WORKDIR}/GensForLinux
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- if use vanilla; then
- epatch \
- "${FILESDIR}"/${P}-gcc4.patch \
- "${FILESDIR}"/${P}-romsdir.patch
- else
- epatch \
- "${FILESDIR}"/gens-rc3_to_mythgame.patch
- fi
- append-ldflags -Wl,-z,noexecstack
-}
-
-src_compile() {
- use amd64 && multilib_toolchain_setup x86
- egamesconf \
- $(use_enable x86 gtktest) || die # shut up and eat emul-linux-x86-gtklibs
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS BUGS README gens.txt history.txt
- prepgamesdirs
-}