summaryrefslogtreecommitdiff
path: root/media-sound/gmpc/gmpc-scm.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/gmpc/gmpc-scm.ebuild')
-rw-r--r--media-sound/gmpc/gmpc-scm.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/media-sound/gmpc/gmpc-scm.ebuild b/media-sound/gmpc/gmpc-scm.ebuild
new file mode 100644
index 0000000..e870d05
--- /dev/null
+++ b/media-sound/gmpc/gmpc-scm.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/gmpc/gmpc-11.8.16.ebuild,v 1.9 2013/03/29 20:46:57 angelos Exp $
+
+EAPI=6
+VALA_MIN_API_VERSION=0.12
+
+inherit gnome2-utils vala autotools git-r3
+
+DESCRIPTION="A GTK+2 client for the Music Player Daemon"
+HOMEPAGE="http://gmpc.wikia.com/wiki/Gnome_Music_Player_Client"
+EGIT_REPO_URI="https://github.com/DaveDavenport/gmpc"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="nls xspf +unique"
+
+RDEPEND="dev-db/sqlite:3
+ >=dev-libs/glib-2.16:2
+ dev-libs/libxml2:2
+ media-libs/glyr
+ >=media-libs/libmpd-11.8
+ net-libs/libsoup:2.4
+ >=x11-libs/gtk+-2.18:2
+ x11-libs/libX11
+ x11-themes/hicolor-icon-theme
+ unique? ( dev-libs/libunique:1 )
+ xspf? ( >=media-libs/libxspf-1.2 )"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ >=dev-util/gob-2.0.17
+ virtual/pkgconfig
+ nls? ( dev-util/intltool
+ sys-devel/gettext )"
+
+DOCS=( AUTHORS README )
+
+src_prepare() {
+ ./autogen.sh
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ --disable-libspiff \
+ --disable-appindicator \
+ --enable-mmkeys \
+ $(use_enable nls) \
+ $(use_enable unique) \
+ $(use_enable xspf libxspf) \
+ --with-extra-version="$(git rev-parse ${EGIT_BRANCH} | cut -c 1-8)"
+}
+
+src_compile() {
+ emake -j1
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }