summaryrefslogtreecommitdiff
path: root/net-im/utox/utox-scm.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/utox/utox-scm.ebuild')
-rw-r--r--net-im/utox/utox-scm.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/net-im/utox/utox-scm.ebuild b/net-im/utox/utox-scm.ebuild
new file mode 100644
index 0000000..906573f
--- /dev/null
+++ b/net-im/utox/utox-scm.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils fdo-mime git-r3 gnome2-utils toolchain-funcs cmake-utils
+
+DESCRIPTION="Lightweight Tox client"
+HOMEPAGE="https://github.com/uTox/uTox.git"
+EGIT_REPO_URI="https://github.com/uTox/uTox.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+dbus +filter_audio"
+
+RDEPEND="net-libs/tox[av]
+ media-libs/freetype
+ filter_audio? ( media-libs/libfilteraudio )
+ media-libs/libv4l
+ media-libs/libvpx
+ media-libs/openal
+ x11-libs/libX11
+ x11-libs/libXext
+ dbus? ( sys-apps/dbus )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+#src_prepare() {
+# epatch_user
+#}
+
+#src_configure() {
+#}
+
+#src_compile() {
+#}
+
+#src_install() {
+#}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}