summaryrefslogtreecommitdiff
path: root/net-misc/tor/tor-scm.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/tor/tor-scm.ebuild')
-rw-r--r--net-misc/tor/tor-scm.ebuild31
1 files changed, 8 insertions, 23 deletions
diff --git a/net-misc/tor/tor-scm.ebuild b/net-misc/tor/tor-scm.ebuild
index 0b56bfc..587ce0f 100644
--- a/net-misc/tor/tor-scm.ebuild
+++ b/net-misc/tor/tor-scm.ebuild
@@ -15,14 +15,14 @@ SRC_URI=""
LICENSE="BSD GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="-bufferevents libressl scrypt seccomp selinux stats systemd tor-hardening transparent-proxy test web"
+IUSE="libressl scrypt seccomp selinux systemd tor-hardening test web"
DEPEND="
- !libressl? ( dev-libs/openssl:0=[-bindist] )
- libressl? ( dev-libs/libressl:= )
+ app-text/asciidoc
+ dev-libs/libevent[ssl]
sys-libs/zlib
- dev-libs/libevent
- bufferevents? ( dev-libs/libevent[ssl] )
+ !libressl? ( dev-libs/openssl:0=[-bindist] )
+ libressl? ( dev-libs/libressl:0= )
scrypt? ( app-crypt/libscrypt )
seccomp? ( sys-libs/libseccomp )
systemd? ( sys-apps/systemd )"
@@ -35,7 +35,6 @@ pkg_setup() {
}
src_prepare() {
-# epatch "${FILESDIR}"/${PN}-0.2.3.14_alpha-torrc.sample.patch
epatch_user
./autogen.sh
}
@@ -47,23 +46,22 @@ src_configure() {
filter-flags -fstrict-aliasing
econf \
+ --localstatedir="${EPREFIX}/var" \
--enable-system-torrc \
--enable-asciidoc \
- --docdir=/usr/share/doc/${PF} \
- $(use_enable stats instrument-downloads) \
- $(use_enable bufferevents) \
+ --disable-unittests \
$(use_enable scrypt libscrypt) \
$(use_enable seccomp) \
$(use_enable systemd) \
$(use_enable tor-hardening gcc-hardening) \
$(use_enable tor-hardening linker-hardening) \
- $(use_enable transparent-proxy transparent) \
$(use_enable web tor2web-mode) \
$(use_enable test unittests) \
$(use_enable test coverage)
}
src_install() {
+ default
readme.gentoo_create_doc
newconfd "${FILESDIR}"/tor.confd tor
@@ -83,16 +81,3 @@ src_install() {
insinto /etc/tor/
newins "${FILESDIR}"/torrc-r1 torrc
}
-
-pkg_postinst() {
- readme.gentoo_pkg_postinst
-
- if [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -eq 8 && $(gcc-micro-version) -ge 1 ]] ; then
- ewarn "Due to a bug in >=gcc-4.8.1, compiling ${P} with -Os leads to an infinite"
- ewarn "loop. See:"
- ewarn
- ewarn " https://trac.torproject.org/projects/tor/ticket/10259"
- ewarn " https://gcc.gnu.org/bugzilla/show_bug.cgi?id=59358"
- ewarn
- fi
-}