summaryrefslogtreecommitdiff
path: root/net-vpn/i2pd/i2pd-scm.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-vpn/i2pd/i2pd-scm.ebuild')
-rw-r--r--net-vpn/i2pd/i2pd-scm.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-vpn/i2pd/i2pd-scm.ebuild b/net-vpn/i2pd/i2pd-scm.ebuild
new file mode 100644
index 0000000..6a98866
--- /dev/null
+++ b/net-vpn/i2pd/i2pd-scm.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils systemd user git-2
+
+DESCRIPTION="A C++ daemon for accessing the I2P anonymous network"
+HOMEPAGE="https://github.com/PurpleI2P/i2pd"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/PurpleI2P/i2pd"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/boost-1.46[threads]
+ dev-libs/crypto++"
+DEPEND="${RDEPEND}
+ || ( >=sys-devel/gcc-4.6 >=sys-devel/clang-3.3 )"
+
+I2PD_USER="${I2PD_USER:-i2pd}"
+I2PD_GROUP="${I2PD_GROUP:-i2pd}"
+
+#CMAKE_USE_DIR="${S}/build"
+
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ mkdir -p "${D}/usr/bin"
+ cp "${S}/i2pd" "${D}/usr/bin"
+ mkdir -p "${D}/var/lib/certificates/"
+ cp -r "${S}/contrib/certificates/" "${D}/var/lib/certificates"
+ dodoc ${S}/docs/*.md
+ doman ${S}/debian/i2pd.1
+}
+
+
+pkg_setup() {
+ enewgroup "${I2PD_GROUP}"
+ enewuser "${I2PD_USER}" -1 -1 "/var/lib/run/${PN}" "${I2PD_GROUP}"
+}