summaryrefslogtreecommitdiff
path: root/sys-apps/hal/hal-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/hal/hal-9999.ebuild')
-rw-r--r--sys-apps/hal/hal-9999.ebuild33
1 files changed, 17 insertions, 16 deletions
diff --git a/sys-apps/hal/hal-9999.ebuild b/sys-apps/hal/hal-9999.ebuild
index 8e31d2c..5b82c97 100644
--- a/sys-apps/hal/hal-9999.ebuild
+++ b/sys-apps/hal/hal-9999.ebuild
@@ -29,6 +29,7 @@ RDEPEND=">=dev-libs/dbus-glib-0.61
>=dev-util/gperf-3.0.3
sys-apps/usbutils
virtual/eject
+ =sys-fs/e2fsprogs-9999
amd64? ( >=sys-apps/dmidecode-2.7 )
dell? ( >=sys-libs/libsmbios-0.13.4 )
disk-partition? ( >=sys-apps/parted-1.8.0 )
@@ -135,7 +136,7 @@ src_unpack() {
# epatch "${FILESDIR}"/hal-0.5.11-ppc64.patch
-# eautoreconf
+ eautoreconf
}
src_compile() {
@@ -188,21 +189,21 @@ src_compile() {
hardware="$hardware --disable-sonypic"
fi
- ./autogen.sh --with-backend=${backend} \
- --with-os-type=gentoo \
- --with-pid-file=/var/run/hald.pid \
- --with-hwdata=/usr/share/misc \
- --with-socket-dir=/var/run/hald \
- --enable-umount-helper \
- $(use_enable apm) \
- $(use_enable debug verbose-mode) \
- $(use_enable disk-partition parted) \
- $(use_enable doc docbook-docs) \
- $(use_enable doc gtk-doc) \
- --docdir=/usr/share/doc/${PF} \
- --localstatedir=/var \
- ${acpi} ${hardware} \
- || die "configure failed"
+# ./autogen.sh --with-backend=${backend} \
+# --with-os-type=gentoo \
+# --with-pid-file=/var/run/hald.pid \
+# --with-hwdata=/usr/share/misc \
+# --with-socket-dir=/var/run/hald \
+# --enable-umount-helper \
+# $(use_enable apm) \
+# $(use_enable debug verbose-mode) \
+# $(use_enable disk-partition parted) \
+# $(use_enable doc docbook-docs) \
+# $(use_enable doc gtk-doc) \
+# --docdir=/usr/share/doc/${PF} \
+# --localstatedir=/var \
+# ${acpi} ${hardware} \
+# || die "configure failed"
econf --with-os-type=gentoo \
--with-pid-file=/var/run/hald.pid \
--with-socket-dir=/var/run/hald \