summaryrefslogtreecommitdiff
path: root/games-emulation/ps2emu-zerogs/ps2emu-zerogs-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/ps2emu-zerogs/ps2emu-zerogs-9999.ebuild')
-rw-r--r--games-emulation/ps2emu-zerogs/ps2emu-zerogs-9999.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/games-emulation/ps2emu-zerogs/ps2emu-zerogs-9999.ebuild b/games-emulation/ps2emu-zerogs/ps2emu-zerogs-9999.ebuild
new file mode 100644
index 0000000..51b186e
--- /dev/null
+++ b/games-emulation/ps2emu-zerogs/ps2emu-zerogs-9999.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+ESVN_REPO_URI="https://pcsx2.svn.sourceforge.net/svnroot/pcsx2/plugins/gs/zerogs/opengl"
+inherit eutils games subversion autotools
+
+DESCRIPTION="PS2Emu ZeroGS OpenGL plugin"
+HOMEPAGE="http://www.pcsx2.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+# I'm seeing better grahics with devbuild on.
+IUSE="debug +devbuild sse2"
+
+RDEPEND="media-gfx/nvidia-cg-toolkit
+ media-libs/glew
+ media-libs/jpeg
+ sys-libs/zlib
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXxf86vm
+ >=x11-libs/gtk+-2"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xf86vidmodeproto"
+
+S="${WORKDIR}/opengl"
+
+src_unpack() {
+ subversion_src_unpack
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-gcc43.patch"
+ epatch "${FILESDIR}/${PN}-devbuild-paths.patch"
+ epatch "${FILESDIR}/${PN}-consistent-naming.patch"
+
+ sed -r -i \
+ -e 's/-O[0-9]\b//g' \
+ -e 's/-fomit-frame-pointer\b//g' \
+ -e 's/C(..)?FLAGS=/C\1FLAGS+=/' \
+ configure.ac || die
+
+ eautoreconf -v --install || die
+ chmod +x configure
+}
+
+src_compile() {
+ egamesconf \
+ $(use_enable devbuild) \
+ $(use_enable debug) \
+ $(use_enable sse2) \
+ || die
+
+ emake || die
+}
+
+src_install() {
+ exeinto "$(games_get_libdir)/ps2emu/plugins"
+ insinto "$(games_get_libdir)/ps2emu/plugins"
+ doexe libZeroGSogl.so.* || die
+ if use devbuild; then
+ doins ps2hw.fx || die
+ doins ctx1/ps2hw_ctx.fx || die
+ else
+ doins Win32/ps2hw.dat || die
+ fi
+ prepgamesdirs
+}